NTC4-P2STL

Incident Report for Hostek

Resolved

This incident has been resolved.
Posted Sep 26, 2026 - 13:06 UTC

Identified

We have identified an issue affecting shared server NTC4-P2STL.

While we do not have an ETA at this time, we are working as quickly as possible.

Please note, this only affects server NTC4-P2STL.

Further updates will be provided as we progress.
Posted Sep 25, 2026 - 20:58 UTC