Phantom - Services unavailable

Incident Report for Hostek

Resolved

This incident has been resolved.
Posted Feb 22, 2026 - 13:53 UTC

Identified

We have identified an issue affecting the Phantom server.
This is affecting a small subset of our UK customers.

Our team is currently working on the fix. Updates will be provided soon.
Posted Feb 21, 2026 - 21:14 UTC
This incident affected: Shared Services.