Issue affecting PayPal Payments

Incident Report for Hostek

Update

We’re still actively investigating this issue. We’ve confirmed it was caused by an updated module within the billing control panel. Resolving this will require assistance from our development team, and at this time, we expect a full resolution within the next few weeks. We appreciate your continued patience while we work toward a permanent fix.

We still recommend contacting our billing team at billing@hostek.com for any questions.
Posted Feb 04, 2026 - 22:22 UTC

Identified

We are aware of a complication affecting our ability to take payments using PayPal.
We're in discussions with our vendor, in the mean time you can make payment by selecting "pay by card" using our Stripe provider.

We do apologize for any inconvenience this may cause.
Please contact our billing team using billing@hostek.com if you have any questions.
Posted Jan 21, 2026 - 15:47 UTC
This incident affects: Client Portal.