Intermittent Email Login Problems - Mail21

Incident Report for Hostek

Resolved

This incident has been resolved.
Posted Sep 14, 2023 - 08:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2023 - 23:17 UTC

Investigating

Between the hours of 2pm to 6pm CST customers may have noticed problems logging into their email. Hostek System Administrators were able to identify congestion that was causing high load and thus intermittent connectivity issues. This has since been resolved.
Posted Sep 12, 2023 - 19:15 UTC