Issue affecting P1 STL

Incident Report for Hostek

Resolved

The issue has resolved
Our team is investigating and reaching out to our upstream provider for more information
Posted Dec 22, 2025 - 05:33 UTC

Investigating

We are investigating an issue is P1 STL

More information will be provided when available.
Posted Dec 22, 2025 - 05:06 UTC
This incident affected: Network Infrastructure (STL Region).