Issue affecting client portal

Incident Report for Hostek

Resolved

This issue has been resolved
Posted Feb 17, 2026 - 15:32 UTC

Investigating

We are aware of an issue currently preventing customers from logging into the billing control panel on https://cp.hostek.com
Our team is working to resolve the issue.
Further updates will be provided.
Posted Feb 17, 2026 - 15:10 UTC
This incident affected: Client Portal.