Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 08, 2025 - 03:07 UTC
Update
Scheduled Maintenance is completed.
Posted Apr 08, 2025 - 03:07 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 08, 2025 - 02:00 UTC
Scheduled
Notice: We are performing essential maintenance on our core networking infrastructure located in Ashburn, VA (ASH), St Louis, MO (STL), and Reading UK (REA). This testing is crucial to enhance the reliability and performance of our network services.
Schedule: Location: Core Network - Ashburn (ASH) - St Louis (STL) - Reading UK (REA)
Date & Time: Monday 7th Apr 2025 @ 21:00 CST
Expected Duration: 15-30mins total during the 4 hour maintenance window.
Impact: During the maintenance period network services will be unavailable for short durations while we test and update crucial redundant network connections Our team will work to keep disruptions to a minimum, we anticipate three or four short durations of downtime each lasting at most 10 to 15 minutes. We anticipate a total outage period of approximately 10-30mins, spread over the four hour maintenance period.
We apologize for any inconvenience this may cause and appreciate your understanding as we work to enhance our services.
Posted Apr 03, 2025 - 14:41 UTC
This scheduled maintenance affected: Network Infrastructure (STL Region, REA Region, ASH Region).