Email Delivery Delays – Mail16

Incident Report for Hostek

Resolved

We have applied a fix, and email processing on mail16 has returned to normal. Previously queued messages are now being delivered, and new messages are processing without delay.

Our administrators are continuing to monitor mail flow and server performance to confirm the service remains stable.
Posted Aug 27, 2026 - 01:58 UTC

Investigating

We are investigating an issue affecting email processing on the mail16 server. Messages may remain queued, outbound delivery may be delayed, and some email clients may experience a timeout when sending.

Webmail remains accessible. Our administrators are actively working to restore normal mail flow. Please avoid repeatedly resending messages, as this could result in duplicate delivery once processing resumes.

We will provide another update as more information becomes available.
Posted Aug 26, 2026 - 21:53 UTC
This incident affected: Shared Services.