Billing Control Panel Inaccessible

Incident Report for Hostek

Resolved

This incident has been resolved.
Posted May 13, 2026 - 10:48 UTC

Monitoring

Mitigation measures have been implemented, and access to the billing control panel has been restored. We are continuing to monitor the situation to ensure the security of customer account data.
Posted May 12, 2026 - 23:08 UTC

Investigating

Due to a proactive security advisory from WHMCS, the platform powering our client area, we have taken the decision to temporarily suspend access to the client area until the necessary security updates have been released and applied.

This is a precautionary measure taken to maintain the stability and security of the platform while the recommended updates are being implemented.

As soon as the updates have been made available, applied, and fully tested, access to the client area will be restored.

We sincerely apologize for any inconvenience caused and appreciate your patience and understanding.
Posted May 12, 2026 - 20:35 UTC
This incident affected: Client Portal.