We have resolved the underlying issue and will continue to closely monitor the network for any further issues. Further information will be provided relating to the cause and our remediation within the next few days.
Posted Mar 30, 2026 - 22:58 UTC
Identified
We have identified and isolated the issue affecting POD2 STL. While systems are currently reporting online, we are continuing to work on the issue and there may be further downtime while we progress through further checks.
We will update this status when have more information
Posted Mar 30, 2026 - 20:51 UTC
Update
Our network engineering team are continuing to work on the issue affecting POD2 STL. We will provide further updates as we move forward.
Posted Mar 30, 2026 - 20:06 UTC
Investigating
We are experiencing an outage for POD2 of our St Louis Datacenter. We will provide more information as it becomes available.
Posted Mar 30, 2026 - 18:34 UTC
This incident affected: Network Infrastructure (STL Region).