Update: Following our investigation, we have confirmed that this incident was caused by a hardware failure within our upstream datacentre provider's network infrastructure.
Our provider has successfully restored services by migrating network traffic onto redundant infrastructure. We will continue to monitor the environment closely while they complete their post-incident investigation and implement any necessary corrective actions.
We apologise for any inconvenience this incident may have caused and appreciate your patience while the issue was resolved.
Posted Jul 06, 2026 - 13:30 UTC
Monitoring
The network issue affecting STL has been resolved. We will continue to closely monitor the network and perform further investigations.
Posted Jul 06, 2026 - 09:56 UTC
Investigating
We are currently investigating a network issue affecting the St Louis network. More information will be provided.
Posted Jul 06, 2026 - 09:00 UTC
This incident affected: Network Infrastructure (STL Region).