What’s Happening One of our production servers experienced underlying hardware issues affecting disk performance. While the system is online and operational, it is currently running in a degraded state while storage is rebuilding. As a result, customers may experience:
Slow website load times - Database (MySQL) errors - Application instability - Email services appear to be functioning normally at this time, and we are continuing to monitor closely.
What We’re Doing We are actively working on two parallel recovery paths to restore full stability as quickly as possible: 1. Hardware Remediation Replacement components are en route and expected within 24 hours. Once installed, we will assess whether this fully resolves the performance degradation. 2. Provisioning a New Server A brand-new server has been procured and is currently being built. This will allow us to restore services onto fresh infrastructure if that path proves faster or more stable. We will proceed with whichever solution restores full service in the shortest and safest timeframe.
What You Can Expect
- Performance may remain inconsistent during the storage rebuild process. - Some database-driven sites may intermittently show errors. - We are prioritizing system stability and data integrity above all else. - We will provide further updates as we reach key milestones.
Longer-Term Improvements Over the next 3–5 months, we will be migrating customers onto new virtualized infrastructure with built-in multi-layer redundancy. This architecture is designed to significantly reduce the risk of hardware-related service disruptions in the future.
Posted Feb 23, 2026 - 23:05 UTC
Update
We are continuing to investigate the issues presented with server "Merlin". The server is currentlty online.
We are aware the MySQL/ MariaDB service is not operating.
We will provide further updates as we have more information
Posted Feb 23, 2026 - 15:25 UTC
Investigating
We are currently investigating an issue with shared server known as "Merlin". This is affecting a small subset of customers hosting out of the UK "ENF" location.