UK Billing Control Panel - Support Widget Missing

Incident Report for Hostek

Resolved

The missing chat widget is back where it should be.
We apologise for any inconvenience that may have caused.
Posted Nov 20, 2025 - 17:21 UTC

Investigating

We are aware the support "Widget" for contacting our support team from the UK billing control panel is not displaying.
For customers needing to contact our teams, please email support@hostek.com
Posted Nov 20, 2025 - 12:28 UTC
This incident affected: Shared Services.