Planned - St Louis Network Maintenance - POD2

Scheduled for Apr 15, 00:01 - 02:01 UTC

Update

Please be aware of network maintenance scheduled for this evening.
A mistake was made in our initial maintenance notice:
Date & Time:
Thursday 14th April 2026 @ 19:00 CDT // 00:00 UTC.

Should say:
Date & Time:
*Tuesday*14th April 2026 @ 19:00 CDT // 00:00 UTC.
Posted Apr 14, 2026 - 13:43 UTC

Scheduled

Notice:
We are performing essential maintenance on our network infrastructure located in St. Louis, MO (POD02). This maintenance is crucial to enhance the reliability and performance of our network services.

Schedule:
Location:
Core Network - St. Louis (POD02)

Date & Time:
Thursday 14th April 2026 @ 19:00 CDT // 00:00 UTC.

Expected Duration:
2 hour maintenance window.

Impact:
During this maintenance window, customers may experience a brief interruption to network connectivity as routing changes are applied.

Each interruption is expected to last no more than 1–2 minutes, and services will automatically reconnect without manual intervention.

In the unlikely event that a rollback is required, an additional interruption of up to 20 minutes may occur while services are restored to their previous state.

We apologize for any inconvenience this may cause and appreciate your understanding as we work to enhance our services.
Posted Apr 13, 2026 - 15:41 UTC
This scheduled maintenance affects: Network Infrastructure (STL Region).