Known intermittent issues in St Louis Data Center

Incident Report for Hostek

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 01:12 UTC

Update

Investigating reports of intermittent downtime.
Posted Apr 13, 2025 - 18:47 UTC

Investigating

We are currently investigating this issue.
Posted Apr 13, 2025 - 18:46 UTC
This incident affected: Network Infrastructure (STL Region).