Issue affecting Billing Client Area and WCP

Incident Report for Hostek

Resolved

Summary:
A small number of systems generated abnormal traffic levels, which placed excessive load on shared infrastructure and caused platform-wide performance degradation.

Impact:
Customers experienced intermittent latency, timeouts, and slower-than-normal service performance.

Resolution:
The affected systems were identified and isolated, and resource contention was mitigated. Platform performance has been fully restored.

Prevention:
We are implementing enhanced monitoring, improved resource isolation, and additional safeguards to better detect and contain similar issues in the future.
Posted Apr 30, 2026 - 23:11 UTC

Investigating

We are aware of the issue with the client area and WCP. We are working to resolve the issue. Thank you for your patience!
Posted Apr 30, 2026 - 18:49 UTC
This incident affected: Client Portal.