Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 20, 2025 - 00:01 UTC
Scheduled
Status: At Risk Location: STL (St. Louis) - USA When: Friday, December 19, 2025, from 6:00 PM to Midnight (CST) // 00:00am to 06:00am (UTC) Expected Duration: Approximately 6 hours
We have been informed of upcoming electrical infrastructure upgrades at the facility where our systems are housed. As part of this work, the utility provider will be carrying out a full-building power shutdown during the window noted above.
During this period, normal building power will be unavailable. Essential building systems such as access control and emergency lighting will remain operational, while non-essential services (including elevators and certain building amenities) will be offline until power is restored.
Service Impact We do not expect any interruption to your servers or hosted services. On site generator systems are fully maintained, tested, and fueled to ensure continuous operation throughout the maintenance. As an added precaution, there will be a complete additional generator inspection the week before the event. Datacenter service teams will also be on-site for the full duration to monitor systems and oversee the transition back to utility power.
If you have any questions, please feel free to reach out to our support team.
Thank you, Hostek Support Team
Posted Dec 11, 2025 - 17:49 UTC
This scheduled maintenance affected: Network Infrastructure (STL Region) and ColdFusion Services, Shared Services, Customer Support, Client Portal.