UK Control Panel - Email issue

Incident Report for Hostek

Resolved

The issue is resolved.
Posted Aug 11, 2025 - 16:17 UTC

Identified

Location: UK
Affecting: Billing Control Panel – https://cp.hostek.co.uk
Issue: Email Delivery Problem

Details:
We are currently experiencing an issue with outgoing email from our UK billing control panel. This may impact the delivery of password reset requests, invoice reminders, and new service welcome messages.

Our team is actively working to restore normal email functionality as quickly as possible. We will provide updates as soon as more information is available.
Posted Aug 11, 2025 - 14:01 UTC
This incident affected: Client Portal.