Mail19 - Unavailable

Incident Report for Hostek

Resolved

The underlying issue and the unplanned maintenance to address ongoing stability has been completed earlier than expected.
The server Mail-19 is now back under normal operation, although we will continue to monitor it closely.
Posted Jan 20, 2026 - 19:39 UTC

Identified

The issue affecting Mail-19 has been identified.
The server has been running normally for a short time.
We now need to proceed with unplanned maintenance in order to keep the service stable and performant moving forward.

We anticipate the maintenance to take no more than 2 hours to complete.
During this time service access will be intermittent.
Expected time of completion: 3pm CST // 9pm UTC.
Posted Jan 20, 2026 - 19:04 UTC

Investigating

We are aware shared mail server "MAIL-19" is currently offline.
We are investigating the cause and will provide updates shortly.
Posted Jan 20, 2026 - 15:48 UTC
This incident affected: Shared Services.